org.apache.activemq:activemq-osgi@5.8.0 vulnerabilities

Puts together an ActiveMQ OSGi bundle

Direct Vulnerabilities

Known vulnerabilities in the org.apache.activemq:activemq-osgi package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Credentials Exposure

org.apache.activemq:activemq-osgi is a messaging and Integration Patterns server.

Affected versions of this package are vulnerable to Credentials Exposure. The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in allows wildcard operators in usernames, which allows remote attackers to obtain credentials via a brute force attack. NOTE: this identifier was SPLIT from CVE-2014-3612 per ADT2 due to different vulnerability types.

How to fix Credentials Exposure?

Upgrade org.apache.activemq:activemq-osgi to version 5.10.1 or higher.

[5.8.0,5.10.1)