org.apache.cxf.fediz:fediz-spring@1.2.4 vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the org.apache.cxf.fediz:fediz-spring package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Cross-site Request Forgery (CSRF)

org.apache.cxf.fediz:fediz-spring is an open source services framework that ships with a number of container-specific plugins to enable WS-Federation for applications.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). The vulnerability can result in a security context that is set up using a malicious client's roles for the given enduser.

How to fix Cross-site Request Forgery (CSRF)?

Upgrade org.apache.cxf.fediz:fediz-spring to version 1.3.0, 1.3.3, 1.4.3 or higher.

[1.2.4,1.3.0) [1.3.2,1.3.3) [1.4.0,1.4.3)