org.apache.geode:geode-core@1.12.4 vulnerabilities

Apache Geode provides a database-like consistency model, reliable transaction processing and a shared-nothing architecture to maintain very low latency performance with high concurrency processing

Direct Vulnerabilities

Known vulnerabilities in the org.apache.geode:geode-core package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • C
Deserialization of Untrusted Data

org.apache.geode:geode-core is a data management platform for cloud architectures.

Affected versions of this package are vulnerable to Deserialization of Untrusted Data when using REST API on Java 8 or Java 11.

How to fix Deserialization of Untrusted Data?

Upgrade org.apache.geode:geode-core to version 1.15.0 or higher.

(,1.15.0)
  • C
Deserialization of Untrusted Data

org.apache.geode:geode-core is a data management platform for cloud architectures.

Affected versions of this package are vulnerable to Deserialization of Untrusted Data when using JMX over RMI on Java 11.

Note: Upgrading to the fix version of the package will automatically protect users on Java 11.

How to fix Deserialization of Untrusted Data?

Upgrade org.apache.geode:geode-core to version 1.15.0 or higher.

(,1.15.0)
  • C
Deserialization of Untrusted Data

org.apache.geode:geode-core is a data management platform for cloud architectures.

Affected versions of this package are vulnerable to Deserialization of Untrusted Data when using JMX over RMI on Java 8.

Note: Users should also upgrade to Java 11.

If upgrading to Java 11 is not possible, then upgrade to the fixed version and specify --J=-Dgeode.enableGlobalSerialFilter=true when starting any Locators or Servers.

How to fix Deserialization of Untrusted Data?

Upgrade org.apache.geode:geode-core to version 1.15.0 or higher.

(,1.15.0)
  • M
Information Exposure

org.apache.geode:geode-core is a data management platform for cloud architectures.

Affected versions of this package are vulnerable to Information Exposure when using values that begin with characters other than letters or numbers for passwords and security properties with the prefix sysprop-, javax.net.ssl, or security-.

How to fix Information Exposure?

Upgrade org.apache.geode:geode-core to version 1.12.5, 1.13.5 or higher.

(,1.12.5) [1.13.0,1.13.5)