org.apache.jspwiki:jspwiki-main@2.11.2 vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the org.apache.jspwiki:jspwiki-main package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Cross-site Scripting (XSS)

org.apache.jspwiki:jspwiki-main is a main release jar for Apache JSPWiki engine.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) via the execute() function in WeblogPlugin.java.

How to fix Cross-site Scripting (XSS)?

Upgrade org.apache.jspwiki:jspwiki-main to version 2.11.3 or higher.

(,2.11.3)
  • M
Cross-site Scripting (XSS)

org.apache.jspwiki:jspwiki-main is a main release jar for Apache JSPWiki engine.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) via the Denounce class, which does not limit scripts from being executed by requests against AJAXPreview.jsp.

NOTE: This vulnerability exists due to an incomplete fix for CVE-2021-40369.

How to fix Cross-site Scripting (XSS)?

Upgrade org.apache.jspwiki:jspwiki-main to version 2.11.3 or higher.

(,2.11.3)
  • M
Cross-site Scripting (XSS)

org.apache.jspwiki:jspwiki-main is a main release jar for Apache JSPWiki engine.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) in the translate() function in XHtmlElementToWikiTranslator.java, which does not limit scripts from being executed by requests against XHRHtml2Markup.jsp.

How to fix Cross-site Scripting (XSS)?

Upgrade org.apache.jspwiki:jspwiki-main to version 2.11.3 or higher.

(,2.11.3)