org.apache.juddi:juddi-client@2.0rc6 vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the org.apache.juddi:juddi-client package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Remote Code Execution (RCE)

org.apache.juddi:juddi-client is a Java implementation of OASIS the Universal Description, Discovery, and Integration (UDDI) specification for (Web) Services.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). Apache jUDDI uses several classes related to Java's Remote Method Invocation (RMI) which (as an extension to UDDI) provides an alternate transport for accessing UDDI services. RMI uses the default Java serialization mechanism to pass parameters in RMI invocations. A remote attacker can send a malicious serialized object to the above RMI entries. The objects get deserialized without any check on the incoming data. In the worst case, it may let the attacker run arbitrary code remotely.

For both jUDDI web service applications and jUDDI clients, the usage of RMI is disabled by default. Since this is an optional feature and an extension to the UDDI protocol, the likelihood of impact is low.

How to fix Remote Code Execution (RCE)?

Upgrade org.apache.juddi:juddi-client to version 3.3.10 or higher.

(,3.3.10)