org.apache.spark:spark-core_2.11@1.2.0 vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the org.apache.spark:spark-core_2.11 package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • C
Arbitrary Code Execution

org.apache.spark:spark-core_2.11 is a cluster computing system for Big Data.

Affected versions of this package are vulnerable to Arbitrary Code Execution. The standalone resource manager accepts code to execute on a 'master' host, that then runs that code on 'worker' hosts. The master itself does not, by design, execute user code. A specially-crafted request to the master can, however, cause the master to execute code too.

Note that this does not affect standalone clusters with authentication enabled. While the master host typically has less outbound access to other resources than a worker, the execution of code on the master is nevertheless unexpected.

How to fix Arbitrary Code Execution?

There is no fixed version for org.apache.spark:spark-core_2.11.

[0,)
  • M
Information Exposure

org.apache.spark:spark-core_2.11 is a cluster computing system for Big Data.

Affected versions of this package are vulnerable to Information Exposure. In certain situations Spark would write user data to local disk unencrypted, even if spark.io.encryption.enabled=true. This includes cached blocks that are fetched to disk (controlled by spark.maxRemoteBlockSizeFetchToMem); in SparkR, using parallelize; in Pyspark, using broadcast and parallelize; and use of python udfs.

How to fix Information Exposure?

Upgrade org.apache.spark:spark-core_2.11 to version 2.3.3 or higher.

(,2.3.3)
  • M
Cross-site Scripting (XSS)

Apache Spark is a general cluster computing system for Big Data.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) attacks. It is possible for a malicious user to construct a URL pointing to a Spark cluster's UI's job and stage info pages, and if a user can be tricked into accessing the URL, can be used to cause script to execute and expose information from the user's view of the Spark UI.

How to fix Cross-site Scripting (XSS)?

Upgrade org.apache.spark:spark-core to version 2.1.3, 2.2.2, 2.3.1 or higher.

(,2.1.3) [2.2.0,2.2.2) [2.3.0,2.3.1)
  • M
Privilege Escalation

org.apache.spark:spark-core_2.11 is a cluster computing system for Big Data.

Affected versions of this package are vulnerable to Privilege Escalation. When using PySpark or SparkR, it was possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.

How to fix Privilege Escalation?

Upgrade org.apache.spark:spark-core_2.11 to version 2.1.3, 2.2.2, 2.3.1 or higher.

(,2.1.3) [2.2.0,2.2.2) [2.3.0,2.3.1)
  • M
Cross-site Scripting (XSS)

org.apache.spark:spark-core is a fast and general cluster computing system for Big Data.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) attacks.

In Apache Spark before 2.2.0, it is possible for an attacker to take advantage of a user's trust in the server to trick them into visiting a link that points to a shared Spark cluster and submits data including MHTML to the Spark master, or history server. This data, which could contain a script, would then be reflected back to the user and could be evaluated and executed by MS Windows-based clients. It is not an attack on Spark itself, but on the user, who may then execute the script inadvertently when viewing elements of the Spark web UIs.

How to fix Cross-site Scripting (XSS)?

Upgrade org.apache.spark:spark-core to version 2.2.0 or higher.

(,2.2.0)
  • M
Cross-site Scripting (XSS)

org.apache.spark:spark-core_2.11 is a fast and general cluster computing system for Big Data.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) attacks.

In Apache Spark before 2.2.0, it is possible for an attacker to take advantage of a user's trust in the server to trick them into visiting a link that points to a shared Spark cluster and submits data including MHTML to the Spark master, or history server. This data, which could contain a script, would then be reflected back to the user and could be evaluated and executed by MS Windows-based clients. It is not an attack on Spark itself, but on the user, who may then execute the script inadvertently when viewing elements of the Spark web UIs.

How to fix Cross-site Scripting (XSS)?

Upgrade org.apache.spark:spark-core_2.11 to version 2.2.0 or higher.

(,2.2.0)