org.eclipse.paho:org.eclipse.paho.client.mqttv3@1.2.0 vulnerabilities

  • latest version

    1.2.5

  • latest non vulnerable version

  • first published

    7 years ago

  • latest version published

    3 years ago

  • licenses detected

  • package manager

Direct Vulnerabilities

Known vulnerabilities in the org.eclipse.paho:org.eclipse.paho.client.mqttv3 package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Insufficient Hostname Verification

org.eclipse.paho:org.eclipse.paho.client.mqttv3 is an an MQTT client library written in Java for developing applications that run on the JVM or other Java compatible platforms such as Android.

Affected versions of this package are vulnerable to Insufficient Hostname Verification. When connecting to an MQTT server using TLS, the package was found to not check the results of setting a host name verifier. This could allow one MQTT server to impersonate another and provide the client library with incorrect information.

How to fix Insufficient Hostname Verification?

Upgrade org.eclipse.paho:org.eclipse.paho.client.mqttv3 to version 1.2.1 or higher.

(,1.2.1)