tinymce@4.8.5 vulnerabilities

Web based JavaScript HTML WYSIWYG editor control.

Direct Vulnerabilities

Known vulnerabilities in the tinymce package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Cross-site Scripting (XSS)

tinymce is a web-based JavaScript HTML WYSIWYG editor control.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) via URLs which are not cleaned correctly in the link and image plugins.

How to fix Cross-site Scripting (XSS)?

Upgrade tinymce to version 5.10.0 or higher.

<5.10.0
  • M
Cross-site Scripting (XSS)

tinymce is a web-based JavaScript HTML WYSIWYG editor control.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) in the schema validation logic of the core parser. The vulnerability allowed arbitrary JavaScript execution when inserting a piece of crafted content into the editor using the clipboard or editor APIs. This malicious content could then end up in content published outside the editor, if no server-side sanitization was performed.

How to fix Cross-site Scripting (XSS)?

Upgrade tinymce to version 5.9.0 or higher.

<5.9.0
  • M
Cross-site Scripting (XSS)

tinymce is a web-based JavaScript HTML WYSIWYG editor control.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS). The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor using the clipboard or APIs, and then submitting the form. However, as TinyMCE does not allow forms to be submitted while editing, the vulnerability could only be triggered when the content was previewed or rendered outside of the editor. NOTE: the vulnerability could only be triggered when the content was previewed or rendered outside of the editor.

How to fix Cross-site Scripting (XSS)?

Upgrade tinymce to version 5.7.1 or higher.

<5.7.1
  • M
Cross-site Scripting (XSS)

tinymce is a web-based JavaScript HTML WYSIWYG editor control.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS). A vulnerability exists within the URL sanitization logic of the core parser. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor using the clipboard or APIs.

How to fix Cross-site Scripting (XSS)?

Upgrade tinymce to version 5.6.0 or higher.

<5.6.0
  • C
Cross-site Scripting (XSS)

tinymce is a web-based JavaScript HTML WYSIWYG editor control.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS). It allows arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs.

How to fix Cross-site Scripting (XSS)?

Upgrade tinymce to version 4.9.11, 5.4.0 or higher.

<4.9.11 >=5.0.0 <5.4.0
  • M
Cross-site Scripting (XSS)

tinymce is a web-based JavaScript HTML WYSIWYG editor control.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) via the media plugin.

How to fix Cross-site Scripting (XSS)?

Upgrade tinymce to version 4.9.10, 5.2.2 or higher.

<4.9.10 >=5.0.0 <5.2.2
  • H
Cross-site Scripting (XSS)

tinymce is a web-based JavaScript HTML WYSIWYG editor control.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) in the core parser, paste and visualchars plugins. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs.

How to fix Cross-site Scripting (XSS)?

Upgrade tinymce to version 5.1.4, 4.9.7 or higher.

>=5.0.0 <5.1.4 <4.9.7