v8n@1.2.1 vulnerabilities

Dead simple fluent JavaScript validation library

Direct Vulnerabilities

Known vulnerabilities in the v8n package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Regular Expression Denial of Service (ReDoS)

v8n is a Dead simple fluent JavaScript validation library

Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) in the lowercase() and uppercase() regex.

How to fix Regular Expression Denial of Service (ReDoS)?

Upgrade v8n to version 1.5.1 or higher.

<1.5.1