vue@1.0.28 vulnerabilities

The progressive JavaScript framework for building modern web UI.

Direct Vulnerabilities

Known vulnerabilities in the vue package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Cross-site Scripting (XSS)

vue is an open source project with its ongoing development made possible entirely by the support of these awesome backers.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS). spread attributes in the ssr files are unsanitized and can therefore be attack vectors for untrusted user input.

How to fix Cross-site Scripting (XSS)?

Upgrade vue to version 2.5.17 or higher.

<2.5.17
  • L
Regular Expression Denial of Service (ReDoS)

vue is a React UI component library that uses inline styles to avoid CSS dependencies and prevent leaky global styles from affecting an application.

Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) attacks. This can cause an impact of about 10 seconds matching time for data 70k characters long.

How to fix Regular Expression Denial of Service (ReDoS)?

Update vue to version 2.5.14 or higher.

<2.5.14
  • M
Cross-site Scripting (XSS)

vue is a Reactive, component-oriented view layer for modern web interfaces.

Affected versions of the package are vulnerable to Cross-site Scripting (XSS).

How to fix Cross-site Scripting (XSS)?

Upgrade vue to version 2.4.3 or higher.

<2.4.3
  • M
Cross-site Scripting (XSS)

vue is a Reactive, component-oriented view layer for modern web interfaces.

Affected versions of the package are vulnerable to Cross-site Scripting (XSS).

How to fix Cross-site Scripting (XSS)?

Upgrade vue to version 2.3.0-beta.1 or higher.

<2.3.0-beta.1