CoAPthon@4.0.2 vulnerabilities

CoAPthon is an implementation of the CoAP protocol.

Direct Vulnerabilities

Known vulnerabilities in the CoAPthon package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Denial of Service (DoS)

CoAPthon is an implementation of the CoAP protocol.

Affected versions of this package are vulnerable to Denial of Service (DoS) via the Serialize.deserialize() method which mishandles certain exceptions.

How to fix Denial of Service (DoS)?

There is no fixed version for CoAPthon.

[3.1,)