Open Redirect Affecting python2.7 package, versions <2.7.12-2


low

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Scope Changed
Expand this section
NVD
6.1 medium
Expand this section
SUSE
6.1 medium
Expand this section
Red Hat
5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN9-PYTHON27-306445
  • published 27 Jun 2018
  • disclosed 27 Nov 2019

How to fix?

Upgrade Debian:9 python2.7 to version 2.7.12-2 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream python2.7 package. See How to fix? for Debian:9 relevant versions.

The CGIHandler class in Python before 2.7.12 does not protect against the HTTP_PROXY variable name clash in a CGI script, which could allow a remote attacker to redirect HTTP requests.