Cryptographic Issues Affecting python2.7 package, versions <2.7.3~rc1-1


low

Snyk CVSS

    Attack Complexity Low
NVD  medium
Expand this section
SUSE
5.3 medium
Red Hat  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN9-PYTHON27-306591
  • published 5 Oct 2012
  • disclosed 5 Oct 2012

How to fix?

Upgrade Debian:9 python2.7 to version 2.7.3~rc1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python2.7 package and not the python2.7 package as distributed by Debian:9. See How to fix? for Debian:9 relevant fixed versions and status.

Python before 2.6.8, 2.7.x before 2.7.3, 3.x before 3.1.5, and 3.2.x before 3.2.3 computes hash values without restricting the ability to trigger hash collisions predictably, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted input to an application that maintains a hash table.