Insecure Permissions Affecting github.com/matryer/moq Open this link in a new tab package, versions <0.1.6


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMMATRYERMOQ-1069819

  • published

    2 Feb 2021

  • disclosed

    2 Feb 2021

  • credit

    matryer

Introduced: 2 Feb 2021

CWE-275 Open this link in a new tab

How to fix?

Upgrade github.com/matryer/moq to version 0.1.6 or higher.

Overview

Affected versions of this package are vulnerable to Insecure Permissions. There are insecure file permissions used when creating a directory.