SQL Injection Affecting phpmyadmin/phpmyadmin package, versions <5.0.2


0.0
high

Snyk CVSS

    Attack Complexity Low
    Scope Changed

    Threat Intelligence

    EPSS 0.06% (26th percentile)
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-PHPMYADMINPHPMYADMIN-3250310
  • published 27 Jan 2023
  • disclosed 27 Jan 2023
  • credit Unknown

How to fix?

Upgrade phpmyadmin/phpmyadmin to version 5.0.2 or higher.

Overview

phpmyadmin/phpmyadmin is a web interface for MySQL and MariaDB.

Affected versions of this package are vulnerable to SQL Injection in the getTableCreationQuery() function in CreateAddField.php via the tbl_storage_engine or tbl_collation parameters.