Access Restriction Bypass Affecting linux_kernel Open this link in a new tab package, versions [,5.17.2)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-UNMANAGED-LINUXKERNEL-2823330

  • published

    12 May 2022

  • disclosed

    12 May 2022

  • credit

    Jann H (jannh@google.com)

How to fix?

Upgrade linux_kernel to version 5.17.2 or higher.

Overview

Affected versions of this package are vulnerable to Access Restriction Bypass by mishandling seccomp permissions. The PTRACE_SEIZE code path allows attackers to bypass intended restrictions on setting the PT_SUSPEND_SECCOMP flag.