glibc vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the glibc package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Out-of-bounds Write

<0:2.28-236.el8_9.13
  • H
Heap-based Buffer Overflow

<0:2.28-225.el8_8.6
  • H
Stack-based Buffer Overflow

<0:2.28-225.el8_8.6
  • H
Use After Free

<0:2.28-225.el8_8.6
  • H
Use After Free

<0:2.28-225.el8_8.6
  • M
Improper Input Validation

<0:2.28-164.el8_5.3
  • M
Improper Input Validation

<0:2.28-164.el8_5.3
  • M
Off-by-one Error

<0:2.28-164.el8_5.3
  • M
Out-of-bounds Write

<0:2.28-127.el8
  • M
Improper Input Validation

<0:2.28-151.el8
  • M
Stack-based Buffer Overflow

<0:2.28-127.el8
  • M
Loop with Unreachable Exit Condition ('Infinite Loop')

<0:2.28-151.el8
  • M
Out-of-Bounds

<0:2.28-151.el8
  • M
Use After Free

<0:2.28-127.el8
  • L
Improper Input Validation

<0:2.28-101.el8
  • M
Out-of-bounds Read

<0:2.28-151.el8
  • M
Integer Overflow or Wraparound

<0:2.28-164.el8
  • M
Use After Free

<0:2.28-164.el8
  • M
Use After Free

<0:2.28-164.el8
  • M
Improper Input Validation

<0:2.28-72.el8
  • M
Loop with Unreachable Exit Condition ('Infinite Loop')

<0:2.28-151.el8