perl vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the perl package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • L
Improper Verification of Cryptographic Signature

*
  • H
Out-of-bounds Write

<5.28.1-6+deb10u1
  • H
Integer Overflow or Wraparound

<5.28.1-6+deb10u1
  • H
Buffer Overflow

<5.28.1-6+deb10u1
  • C
Out-of-bounds Read

<5.28.0-3
  • C
Out-of-Bounds

<5.28.1-1
  • C
Out-of-bounds Write

<5.28.1-1
  • C
Out-of-Bounds

<5.28.0-3
  • C
Arbitrary Code Injection

<5.18.1-2
  • L
Link Following

*
  • H
Link Following

<5.26.2-6
  • C
Out-of-bounds Write

<5.26.1-6
  • H
Out-of-bounds Read

<5.26.1-6
  • C
Out-of-bounds Write

<5.26.1-6
  • H
Out-of-Bounds

<5.26.0-8
  • C
Out-of-Bounds

<5.26.0-8
  • M
Race Condition

<5.24.1-3
  • H
Access Restriction Bypass

<5.22.2-3
  • H
CVE-2016-6185

<5.22.2-2
  • H
Improper Input Validation

<5.22.1-1
  • H
Improper Input Validation

<5.22.1-8
  • H
Improper Input Validation

<5.22.1-4
  • H
Numeric Errors

<5.20.0-1
  • M
Out-of-Bounds

<5.20.1-1
  • L
Improper Input Validation

<5.20.1-1
  • H
Resource Management Errors

<5.14.2-19
  • H
Arbitrary Code Injection

<5.14.2-16
  • L
CVE-2011-2728

<5.14.2-1
  • H
Out-of-Bounds

<5.14.2-14
  • M
Configuration

<5.14.2-16
  • L
Improper Input Validation

<5.12.4-6
  • L
Numeric Errors

<5.12.4-4
  • L
CVE-2011-0761

<5.12.0-1
  • L
Access Restriction Bypass

<5.10.1-20
  • M
CVE-2010-4411

<5.10.1-17
  • M
Arbitrary Code Injection

<5.10.1-17
  • M
Arbitrary Code Injection

<5.10.1-17
  • H
Access Restriction Bypass

<5.10.1-13
  • H
Access Restriction Bypass

<5.12.3-1
  • M
CVE-2009-3626

<5.10.1-6
  • L
Numeric Errors

<5.10.0-23
  • H
Race Condition

<5.10.0-18
  • H
Race Condition

<5.10.0-18
  • M
Access Restriction Bypass

<5.10.0-11
  • M
Resource Management Errors

<5.10.0-1
  • M
Out-of-Bounds

<5.8.8-12
  • M
Directory Traversal

<5.10.0-19
  • M
Numeric Errors

<5.8.7-9
  • L
CVE-2005-0448

<5.8.4-7
  • M
CVE-2005-0155

<5.8.4-6
  • M
CVE-2004-0976

<5.8.4-4
  • M
CVE-2005-0156

<5.8.4-6
  • M
CVE-2004-0452

<5.8.4-5
  • M
CVE-2003-0618

<5.8.3-3
  • M
CVE-2003-0900

<5.8.2
  • M
CVE-2003-0615

<5.8.0-19
  • M
CVE-2002-1323

<5.8.0-14
  • H
CVE-2002-0703

<5.8.0-7