systemd vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the systemd package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • L
CVE-2023-50868

*
  • H
Allocation of Resources Without Limits or Throttling

*
  • L
CVE-2023-7008

*
  • L
Improper Validation of Integrity Check Value

*
  • L
Improper Validation of Integrity Check Value

*
  • L
Improper Validation of Integrity Check Value

*
  • H
CVE-2023-26604

<247.1-2
  • M
CVE-2022-4415

<247.3-7+deb11u2
  • M
Off-by-one Error

<247.3-7+deb11u2
  • C
Use After Free

<240-1
  • M
Uncontrolled Recursion

<247.3-7
  • M
Allocation of Resources Without Limits or Throttling

<247.3-6
  • L
Authentication Bypass

*
  • L
Improper Input Validation

<246-2
  • H
Use After Free

<244.2-1
  • L
Missing Release of Resource after Effective Lifetime

<243-5
  • L
Improper Certificate Validation

<244-1
  • M
CVE-2019-15718

<242-7
  • H
Privilege Chaining

<242-4
  • H
Incorrect Privilege Assignment

<242-4
  • H
Improper Authorization

<241-3
  • M
Out-of-Bounds

<240-6
  • H
Allocation of Resources Without Limits or Throttling

<240-4
  • H
Allocation of Resources Without Limits or Throttling

<240-4
  • L
Out-of-bounds Read

<240-1
  • L
Improper Input Validation

<237-1
  • H
Out-of-Bounds

<239-11
  • H
Deserialization of Untrusted Data

<239-12
  • H
Race Condition

<239-11
  • M
CVE-2012-1101

<43-1
  • M
Race Condition

<234-1
  • L
CVE-2018-6954

<238-1
  • L
Link Following

<237-1
  • H
Loop with Unreachable Exit Condition ('Infinite Loop')

<235-3
  • C
Out-of-Bounds

<229-1
  • L
Improper Input Validation

<234-1
  • H
Out-of-bounds Write

<233-10
  • H
Improper Input Validation

<232-24
  • H
Access Restriction Bypass

<229-1
  • M
Improper Input Validation

<231-9
  • M
Improper Input Validation

<231-9
  • L
Access Restriction Bypass

<215-1
  • L
Access Restriction Bypass

<215-1
  • H
Link Following

<43-1
  • L
Link Following

*
  • M
CVE-2013-4393

<204-5
  • M
Incorrect Default Permissions

<204-5
  • H
Integer Overflow or Wraparound

<204-5
  • H
CVE-2013-4327

<204-5
  • M
Race Condition

<44-1