libxml2 vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the libxml2 package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Out-of-Bounds

<0:2.9.7-18.el8_9
  • M
Double Free

<0:2.9.7-16.el8_8.1
  • M
NULL Pointer Dereference

<0:2.9.7-16.el8_8.1
  • M
Integer Overflow or Wraparound

<0:2.9.7-15.el8_7.1
  • M
Double Free

<0:2.9.7-15.el8_7.1
  • M
Cross-site Scripting (XSS)

<0:2.9.7-15.el8
  • M
Integer Overflow or Wraparound

<0:2.9.7-13.el8_6.1
  • M
Use After Free

<0:2.9.7-12.el8_5
  • M
Use After Free

<0:2.9.7-9.0.1.el8_4.2
  • M
Improper Restriction of Recursive Entity References in DTDs ('XML Entity Expansion')

<0:2.9.7-9.0.1.el8_4.2
  • M
Use After Free

<0:2.9.7-9.0.1.el8_4.2
  • M
Out-of-bounds Write

<0:2.9.7-9.0.1.el8_4.2
  • M
NULL Pointer Dereference

<0:2.9.7-9.0.1.el8_4.2
  • M
Out-of-bounds Read

<0:2.9.7-9.0.1.el8
  • M
Memory Leak

<0:2.9.7-8.0.1.el8
  • M
Memory Leak

<0:2.9.7-8.0.1.el8
  • M
Loop with Unreachable Exit Condition ('Infinite Loop')

<0:2.9.7-8.0.1.el8
  • M
Loop with Unreachable Exit Condition ('Infinite Loop')

<0:2.9.7-7.0.1.el8
  • M
NULL Pointer Dereference

<0:2.9.7-7.0.1.el8