org.apache.cxf.fediz:fediz-core@1.2.2 vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the org.apache.cxf.fediz:fediz-core package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
XML External Entity (XXE) Injection

org.apache.cxf.fediz:fediz-core helps to secure the web applications by delegating security enforcement to the underlying application server.

Affected versions of this package are vulnerable to XML External Entity (XXE) Injection due to not fully disable DTDs.

How to fix XML External Entity (XXE) Injection?

Upgrade org.apache.cxf.fediz:fediz-core to version 1.4.4 or higher.

(,1.4.4)
  • C
Improper Access Control

org.apache.cxf.fediz:fediz-core is a package helping secure web applications by delegating security enforcement to the underlying application server.

Affected versions of this package are vulnerable to Improper Access Control. It does not match SAML AudienceRestriction values against configured audience URIs, which might allow remote attackers to have bypass intended restrictions and have unspecified other impact via a crafted SAML token with a trusted signature.

How to fix Improper Access Control?

Upgrade org.apache.cxf.fediz:fediz-core to version 1.2.3, 1.3.1 or higher.

[1.2.0,1.2.3) [1.3.0,1.3.1)