org.apache.derby:derby@10.1.1.0 vulnerabilities

Contains the core Apache Derby database engine, which also includes the embedded JDBC driver.

Direct Vulnerabilities

Known vulnerabilities in the org.apache.derby:derby package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Information Exposure

org.apache.derby:derby is a database engine by Apache.

Affected versions of this package are vulnerable to Information Exposure. It exposes the (1) user and (2) password attributes in cleartext via (a) the RDBNAM parameter of the ACCSEC command and (b) the output of the DatabaseMetaData.getURL function, which allows context-dependent attackers to obtain sensitive information.

How to fix Information Exposure?

Upgrade org.apache.derby:derby to version 10.1.2.1 or higher.

(,10.1.2.1)
  • H
Arbitrary File Overwrite

org.apache.derby:derby is a pure Java, standards-based relational database engine.

Affected versions of the package are vulnerable to Arbitrary File Overwrite. In Apache Derby 10.1.2.1, 10.2.2.0, 10.3.1.4, and 10.4.1.3, Export processing may allow an attacker to overwrite an existing file.

How to fix Arbitrary File Overwrite?

Upgrade org.apache.derby:derby to version 10.6.2.1 or higher.

(,10.6.2.1)