org.apache.derby:derby@10.5.3.0_1 vulnerabilities

Contains the core Apache Derby database engine, which also includes the embedded JDBC driver.

Direct Vulnerabilities

Known vulnerabilities in the org.apache.derby:derby package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Security Bypass

org.apache.derby:derby is a subproject of the Apache DB project.

Affected versions of this package are vulnerable to Security Bypass. A specially-crafted network packet can be used to request the Derby Network Server to boot a database whose location and contents are under the user's control.

How to fix Security Bypass?

Upgrade org.apache.derby:derby to version 10.14.2.0 or higher.

[10.3.1.4,10.14.2.0)
  • H
Arbitrary File Overwrite

org.apache.derby:derby is a pure Java, standards-based relational database engine.

Affected versions of the package are vulnerable to Arbitrary File Overwrite. In Apache Derby 10.1.2.1, 10.2.2.0, 10.3.1.4, and 10.4.1.3, Export processing may allow an attacker to overwrite an existing file.

How to fix Arbitrary File Overwrite?

Upgrade org.apache.derby:derby to version 10.6.2.1 or higher.

(,10.6.2.1)
  • M
Use of Password Hash With Insufficient Computational Effort

org.apache.derby:derby is a database engine by Apache.

Affected versions of this package are vulnerable to Use of Password Hash With Insufficient Computational Effort. The password hash generation algorithm in the BUILTIN authentication functionality for Apache Derby before 10.6.1.0 performs a transformation that reduces the size of the set of inputs to SHA-1, which produces a small search space that makes it easier for local and possibly remote attackers to crack passwords by generating hash collisions, related to password substitution.

How to fix Use of Password Hash With Insufficient Computational Effort?

Upgrade org.apache.derby:derby to version 10.6.1.0 or higher.

[10.5.3.0,10.6.1.0)