org.apache.kafka:generator vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the org.apache.kafka:generator package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Memory Allocation with Excessive Size Value

[2.8.0,2.8.2) [3.0.0,3.0.2) [3.1.0,3.1.2) [3.2.0,3.2.3)

Package versions

1 - 20 of 20 Results
version published direct vulnerabilities
3.2.3 13 Sep, 2022
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
3.2.2 2 Sep, 2022
  • 0
    C
  • 1
    H
  • 0
    M
  • 0
    L
3.2.1 22 Jul, 2022
  • 0
    C
  • 1
    H
  • 0
    M
  • 0
    L
3.2.0 3 May, 2022
  • 0
    C
  • 1
    H
  • 0
    M
  • 0
    L
3.1.2 2 Sep, 2022
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
3.1.1 29 Apr, 2022
  • 0
    C
  • 1
    H
  • 0
    M
  • 0
    L
3.1.0 12 Jan, 2022
  • 0
    C
  • 1
    H
  • 0
    M
  • 0
    L
3.0.2 2 Sep, 2022
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
3.0.1 3 Mar, 2022
  • 0
    C
  • 1
    H
  • 0
    M
  • 0
    L
3.0.0 8 Sep, 2021
  • 0
    C
  • 1
    H
  • 0
    M
  • 0
    L
2.8.2 2 Sep, 2022
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
2.8.1 14 Sep, 2021
  • 0
    C
  • 1
    H
  • 0
    M
  • 0
    L
2.8.0 14 Apr, 2021
  • 0
    C
  • 1
    H
  • 0
    M
  • 0
    L
2.7.2 12 Oct, 2021
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
2.7.1 8 Apr, 2021
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
2.7.0 16 Dec, 2020
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
2.6.3 12 Oct, 2021
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
2.6.2 8 Apr, 2021
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
2.6.1 10 Dec, 2020
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
2.6.0 28 Jul, 2020
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L