org.apache.karaf.shell:org.apache.karaf.shell.core@4.0.0 vulnerabilities

This bundle provides OSGi shell integration and console support.

Direct Vulnerabilities

Known vulnerabilities in the org.apache.karaf.shell:org.apache.karaf.shell.core package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Arbitrary File Read

org.apache.karaf:karaf is a modern and polymorphic applications container.

Affected versions of this package are vulnerable to arbitrary File Read. If the sshd service in Karaf is left on, Any user with rights to the Karaf console can pivot and read/write any file on the file system to which the Karaf process user has access.

How to fix Arbitrary File Read?

Upgrade org.apache.karaf.shell:org.apache.karaf.shell.core to version 4.2.0 or higher.

(,4.2.0)