org.apache.myfaces.trinidad:trinidad-impl@1.2.4 vulnerabilities

Private implementation of the Apache MyFaces Trinidad project

Direct Vulnerabilities

Known vulnerabilities in the org.apache.myfaces.trinidad:trinidad-impl package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • C
Deserialization of Untrusted Data

org.apache.myfaces.trinidad:trinidad-impl is a Private implementation of the Apache MyFaces Trinidad project

Affected versions of this package are vulnerable to Deserialization of Untrusted Data. CoreResponseStateManager might allow attackers to conduct deserialization attacks via a crafted serialized view state string.

How to fix Deserialization of Untrusted Data?

Upgrade org.apache.myfaces.trinidad:trinidad-impl to version 1.2.15, 2.0.2, 2.1.2 or higher.

[1.0.0,1.2.15) [2.0.0,2.0.2) [2.1.0,2.1.2)
  • M
Cryptographic Issues

org.apache.myfaces.trinidad:trinidad-impl is a Private implementation of the Apache MyFaces Trinidad project

Affected versions of this package are vulnerable to Cryptographic Issues as it uses an encrypted View State without a Message Authentication Code (MAC), which makes it easier for remote attackers to perform successful modifications of the View State via a padding oracle attack.

How to fix Cryptographic Issues?

Upgrade org.apache.myfaces.trinidad:trinidad-impl to version 1.1.8, 1.2.9, 2.0.1 or higher.

[1.1.0,1.1.8) [1.2.0,1.2.9) [2.0.0,2.0.1)