org.apache.tomcat:catalina@6.0.51 vulnerabilities

Tomcat Servlet Engine Core Classes and Standard implementations

Direct Vulnerabilities

Known vulnerabilities in the org.apache.tomcat:catalina package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Arbitrary Code Execution

org.apache.tomcat:catalina is a Servlet Engine Core Classes and Standard implementations.

Affected versions of this package are vulnerable to Arbitrary Code Execution. When running Apache Tomcat versions 9.0.0.M1 to 9.0.0, 8.5.0 to 8.5.22, 8.0.0.RC1 to 8.0.46 and 7.0.0 to 7.0.81 with HTTP PUTs enabled (e.g. via setting the readonly initialisation parameter of the Default servlet to false) it was possible to upload a JSP file to the server via a specially crafted request. This JSP could then be requested and any code it contained would be executed by the server.

This is due to an incomplete fix for CVE-2017-12615.

How to fix Arbitrary Code Execution?

There is no fixed version for org.apache.tomcat:catalina.

[0,)
  • L
Directory Traversal

org.apache.tomcat:catalina is a Servlet Engine Core Classes and Standard implementations.

Affected versions of this package are vulnerable to Directory Traversal. When running within a SecurityManager, does not make the ServletContext attribute read-only, which allows local web applications to read or write files outside of the intended working directory, as demonstrated using a directory traversal attack.

How to fix Directory Traversal?

Upgrade org.apache.tomcat:catalina to version 6.0.53 or higher.

[6.0.13,6.0.53)