org.bouncycastle:bcprov-jdk15 vulnerabilities

The Bouncy Castle Crypto package is a Java implementation of cryptographic algorithms. This jar contains JCE provider and lightweight API for the Bouncy Castle Cryptography APIs for JDK 1.5.

  • latest version

    1.46

  • first published

    13 years ago

  • latest version published

    12 years ago

  • licenses detected

  • package manager

Direct Vulnerabilities

Known vulnerabilities in the org.bouncycastle:bcprov-jdk15 package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • C
Hash Collision

[0,)
  • M
Cryptographic Issues

[0,)
  • M
Cryptographic Issues

[0,)

Package versions

1 - 7 of 7 Results
version published direct vulnerabilities
1.46 23 Feb, 2011
  • 1
    C
  • 0
    H
  • 2
    M
  • 0
    L
1.45 11 Jan, 2010
  • 1
    C
  • 0
    H
  • 2
    M
  • 0
    L
1.44 6 Oct, 2009
  • 1
    C
  • 0
    H
  • 2
    M
  • 0
    L
1.43 10 Jun, 2009
  • 1
    C
  • 0
    H
  • 2
    M
  • 0
    L
1.40 9 Jul, 2009
  • 1
    C
  • 0
    H
  • 2
    M
  • 0
    L
1.38 9 Jul, 2009
  • 1
    C
  • 0
    H
  • 2
    M
  • 0
    L
1.32 9 Jul, 2009
  • 1
    C
  • 0
    H
  • 2
    M
  • 0
    L