@angular/core@9.0.0 vulnerabilities

Angular - the core framework

Direct Vulnerabilities

Known vulnerabilities in the @angular/core package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • L
Cross-site Scripting (XSS)

@angular/core is a package that lets you write client-side web applications as if you had a smarter browser. It also lets you use HTML as your template language and lets you extend HTML’s syntax to express your application’s components clearly and succinctly.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) in development, with SSR enabled.

How to fix Cross-site Scripting (XSS)?

Upgrade @angular/core to version 11.0.5, 11.1.0-next.3 or higher.

<11.0.5 >=11.1.0-next.0 <11.1.0-next.3