@berslucas/liljs@1.0.0

A DOM-driven micro-framework for Javascript applications

  • latest version

    4.0.2

  • latest non vulnerable version

  • first published

    7 years ago

  • latest version published

    7 years ago

  • licenses detected

  • Direct Vulnerabilities

    Known vulnerabilities in the @berslucas/liljs package. This does not include vulnerabilities belonging to this package’s dependencies.

    Fix vulnerabilities automatically

    Snyk's AI Trust Platform automatically finds the best upgrade path and integrates with your development workflows. Secure your code at zero cost.

    Fix for free
    VulnerabilityVulnerable Version
    • M
    Cross-site Scripting (XSS)

    @berslucas/liljs is a DOM-driven micro-framework for JavaScript applications.

    Affected versions of this package are vulnerable to Cross-site Scripting (XSS) due to unsafe usage of innerHTML instead of treating user input as textContent.

    How to fix Cross-site Scripting (XSS)?

    Upgrade @berslucas/liljs to version 1.0.2 or higher.

    <1.0.2