@better-auth/kysely-adapter@1.6.32

Kysely adapter for Better Auth

  • latest version

    1.7.18

  • latest non vulnerable version

  • first published

    9 months ago

  • latest version published

    2 days ago

  • licenses detected

  • Direct Vulnerabilities

    Known vulnerabilities in the @better-auth/kysely-adapter package. This does not include vulnerabilities belonging to this package’s dependencies.

    Fix vulnerabilities automatically

    Snyk's AI Trust Platform automatically finds the best upgrade path and integrates with your development workflows. Secure your code at zero cost.

    Fix for free
    VulnerabilityVulnerable Version
    • M
    Brute Force

    @better-auth/kysely-adapter is a Kysely adapter for Better Auth

    Affected versions of this package are vulnerable to Brute Force via a race condition in the compare-and-swap UPDATE path in drizzle-adapter.ts and relations-v2/index.ts. Under PostgreSQL's READ COMMITTED isolation, the WHERE guard used to identify the target row was placed only in a subquery (id IN (targetIds)), which PostgreSQL does not re-evaluate after waiting on a concurrent writer. As a result, multiple concurrent UPDATE operations can all succeed once the first writer commits, allowing a second (or later) writer to overwrite a row even when the original guard condition is no longer satisfied. An attacker who can issue concurrent write requests can exploit this window to corrupt or overwrite record state they should not be able to modify.

    How to fix Brute Force?

    Upgrade @better-auth/kysely-adapter to version 1.7.0 or higher.

    >=1.6.17 <1.7.0