@hapi/ammo@4.0.1 vulnerabilities

HTTP Range processing utilities

Direct Vulnerabilities

Known vulnerabilities in the @hapi/ammo package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Denial of Service (DoS)

@hapi/ammo is a HTTP Range processing utilities library.

Affected versions of this package are vulnerable to Denial of Service (DoS). The Range HTTP header parser has a vulnerability which will cause the function to throw a system error if the header is set to an invalid value. Because hapi is not expecting the function to ever throw, the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.

How to fix Denial of Service (DoS)?

Upgrade @hapi/ammo to version 3.1.2, 5.0.1 or higher.

<3.1.2 >=4.0.0 <5.0.1