Incorrect Authorization@n8n/n8n-nodes-langchain is a 
Affected versions of this package are vulnerable to Incorrect Authorization via the Execute Sub-workflow. An attacker can access unauthorized credentials by referencing credential IDs within inline workflow JSON, bypassing intended access controls.
Note: This is only exploitable if workflow sharing is enabled and the attacker has been explicitly granted Editor access to a shared workflow, and knows the target credential's ID.
How to fix Incorrect Authorization? Upgrade @n8n/n8n-nodes-langchain to version 1.122.46, 2.31.3, 2.32.1 or higher.
| <1.122.46>=2.0.0-rc.0 <2.31.3>=2.32.0 <2.32.1 |
Server-side Request Forgery (SSRF)@n8n/n8n-nodes-langchain is a 
Affected versions of this package are vulnerable to Server-side Request Forgery (SSRF) in the MCP Client. An attacker can access internal or otherwise restricted network resources by supplying crafted endpoints, causing the server to connect to unintended hosts and return sensitive responses through workflow execution.
Note: This is only exploitable if SSRF protection is enabled and the attacker has permissions to create or edit workflows.
How to fix Server-side Request Forgery (SSRF)? Upgrade @n8n/n8n-nodes-langchain to version 2.31.3, 2.32.1 or higher.
| |
Cross-site Scripting (XSS)@n8n/n8n-nodes-langchain is a 
Affected versions of this package are vulnerable to Cross-site Scripting (XSS) via the ChatTrigger template rendering in ChatTrigger/templates.ts. An authenticated user who can create or edit workflows can inject malicious JavaScript by supplying crafted Custom CSS in a Chat Trigger node, and anyone visiting the public chat page will execute it. The flaw allows the attacker to persist a script in the workflow configuration and have it run in other users’ browsers at the chat URL, exposing session data or enabling actions in the victim’s browser under their identity.
Notes
- The vulnerable flow is the HTML template used by the public chat page, so the stored payload runs wherever that chat URL is rendered rather than only inside the workflow editor.
- The issue is gated by workflow edit/create permissions: only users who can modify workflows can place the malicious
Custom CSS into the Chat Trigger node.
Workarounds
- Limit workflow creation and editing permissions to fully trusted users only, which reduces the chance that an untrusted authenticated user can store malicious Custom CSS in a Chat Trigger workflow.
- Disable the Chat Trigger node by adding
@n8n/n8n-nodes-langchain.chatTrigger to the NODES_EXCLUDE environment variable, which prevents the vulnerable public chat page from being exposed.
How to fix Cross-site Scripting (XSS)? Upgrade @n8n/n8n-nodes-langchain to version 1.122.19, 2.13.1, 2.14.1 or higher.
| <1.122.19>=2.0.0-rc.0 <2.13.1<2.14.1 |
User Impersonation@n8n/n8n-nodes-langchain is a 
Affected versions of this package are vulnerable to User Impersonation via the MicrosoftAgent365Trigger node failing to validate inbound requests. An attacker can execute workflows with attacker-controlled data by submitting forged payloads to the webhook URL.
How to fix User Impersonation? Upgrade @n8n/n8n-nodes-langchain to version 2.25.2, 2.26.1 or higher.
| >=2.7.0 <2.25.2>=2.26.0 <2.26.1 |
Cross-site Scripting (XSS)@n8n/n8n-nodes-langchain is a 
Affected versions of this package are vulnerable to Cross-site Scripting (XSS) via the webhookId parameter in the Chat Trigger node. An attacker can execute arbitrary JavaScript in the context of another user's session by injecting malicious code, which is then triggered when a logged-in user visits the affected chat URL.
How to fix Cross-site Scripting (XSS)? Upgrade @n8n/n8n-nodes-langchain to version 1.122.39, 2.25.2, 2.26.1 or higher.
| <1.122.39>=2.0.0-rc.0 <2.25.2>=2.26.0 <2.26.1 |