@payloadcms/next@4.0.0-canary.32

  • latest version

    3.92.1

  • latest non vulnerable version

  • first published

    2 years ago

  • latest version published

    1 hours ago

  • licenses detected

  • Direct Vulnerabilities

    Known vulnerabilities in the @payloadcms/next package. This does not include vulnerabilities belonging to this package’s dependencies.

    Fix vulnerabilities automatically

    Snyk's AI Trust Platform automatically finds the best upgrade path and integrates with your development workflows. Secure your code at zero cost.

    Fix for free
    VulnerabilityVulnerable Version
    • C
    Partial String Comparison

    Affected versions of this package are vulnerable to Partial String Comparison via the isPublicAdminRoute utility in packages/next/src/utilities/isPublicAdminRoute.ts, which incorrectly marks any route containing the substring /verify/ as a public admin route, regardless of whether it corresponds to a valid collection with authentication enabled. An attacker can craft a request path that includes /verify/ to bypass admin authentication checks and gain unauthorized access to protected admin routes.

    How to fix Partial String Comparison?

    Upgrade @payloadcms/next to version 3.90.0, 4.0.0-canary.34 or higher.

    <3.90.0>=4.0.0-canary.0 <4.0.0-canary.34
    • M
    Overly Restrictive Account Lockout Mechanism

    Affected versions of this package are vulnerable to Overly Restrictive Account Lockout Mechanism via the resetPassword operation, which fails to reset the account lockout state upon a successful password reset. An attacker who triggers repeated failed login attempts to lock an account can keep that account locked even after the legitimate user resets their password, causing a crash of the authentication flow for that user.

    How to fix Overly Restrictive Account Lockout Mechanism?

    Upgrade @payloadcms/next to version 3.90.0, 4.0.0-canary.34 or higher.

    <3.90.0>=4.0.0-canary.0 <4.0.0-canary.34