@payloadcms/plugin-mcp@3.62.0-internal.2a2d1e1

MCP (Model Context Protocol) capabilities with Payload

  • latest version

    3.92.1

  • latest non vulnerable version

  • first published

    1 years ago

  • latest version published

    23 minutes ago

  • licenses detected

  • Direct Vulnerabilities

    Known vulnerabilities in the @payloadcms/plugin-mcp package. This does not include vulnerabilities belonging to this package’s dependencies.

    Fix vulnerabilities automatically

    Snyk's AI Trust Platform automatically finds the best upgrade path and integrates with your development workflows. Secure your code at zero cost.

    Fix for free
    VulnerabilityVulnerable Version
    • H
    SQL Injection

    @payloadcms/plugin-mcp is a MCP (Model Context Protocol) capabilities with Payload

    Affected versions of this package are vulnerable to SQL Injection via improper escaping of string values in parseParams when constructing JSON queries for in and not_in operators. An authenticated attacker can supply a string value containing a single-quote character in a query parameter to break out of the intended SQL literal context and inject arbitrary SQL, achieving full read and write access to the database.

    How to fix SQL Injection?

    Upgrade @payloadcms/plugin-mcp to version 3.73.0 or higher.

    <3.73.0
    • H
    Missing Authorization

    @payloadcms/plugin-mcp is a MCP (Model Context Protocol) capabilities with Payload

    Affected versions of this package are vulnerable to Missing Authorization via the MCP API Keys collection in createApiKeysCollection.ts, which prior to the fix applied no access controls to the generated payload-mcp-api-keys collection. An authenticated user can create API keys bound to any other user, read or modify those keys, and thereby impersonate arbitrary users within the application.

    How to fix Missing Authorization?

    Upgrade @payloadcms/plugin-mcp to version 3.88.0 or higher.

    >=3.61.0 <3.88.0
    • M
    Cross-site Scripting (XSS)

    @payloadcms/plugin-mcp is a MCP (Model Context Protocol) capabilities with Payload

    Affected versions of this package are vulnerable to Cross-site Scripting (XSS) in the admin panel when user-supplied content is saved in a collection with versions enabled. An attacker can execute arbitrary scripts in the context of another user's browser by submitting crafted input and having it viewed by another authenticated user.

    Note:

    This is only exploitable if at least one collection has versions enabled and an authenticated user has create or update access to that collection.

    How to fix Cross-site Scripting (XSS)?

    Upgrade @payloadcms/plugin-mcp to version 3.78.0 or higher.

    <3.78.0