@sap-cloud-sdk/core@1.37.1-20210209162823.47 vulnerabilities

SAP Cloud SDK for JavaScript core

Direct Vulnerabilities

Known vulnerabilities in the @sap-cloud-sdk/core package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Information Exposure

@sap-cloud-sdk/core is a This package contains the core functionality of the SAP Cloud SDK as well as the Cloud Platform abstractions.

Affected versions of this package are vulnerable to Information Exposure. When user information is missing, destinations are cached without user information, allowing other users to retrieve the same destination with its permissions. By default, destination caching is disabled.

Note: This affects applications on SAP Business Technology Platform that use the SAP Cloud SDK and enabled caching of destinations.

How to fix Information Exposure?

Upgrade @sap-cloud-sdk/core to version 1.52.0 or higher.

<1.52.0