@theia/plugin-ext@0.4.0-next.ab06a80d vulnerabilities

Theia - Plugin Extension

  • latest version

    1.51.0

  • latest non vulnerable version

  • first published

    6 years ago

  • latest version published

    22 days ago

  • licenses detected

    • >=0.3.12 <0.4.0-next.70567252; >=0.4.0-next.80121840 <0.4.0-next.3216adc8; >=0.4.0-next.322e9307 <0.4.0-next.3241dd5f; >=0.4.0-next.3302096b <0.4.0-next.48a4697f; >=0.4.0-next.48aeff5a <0.4.0-next.4dfc3274; >=0.4.0-next.4e1bc9eb <0.4.0-next.5508eba5; >=0.4.0-next.558d4b53 <0.4.0-next.750ffc54; >=0.4.0-next.75422c87 <0.4.0-next.7da249dd; >=0.4.0-next.7df95eb5 <0.4.0-next.86654a02; >=0.4.0-next.86a6c9ee <0.4.0-next.8a5132e5; >=0.4.0-next.8a8bf17e <0.4.0-next.aa7754c9; >=0.4.0-next.aa9a92d2 <0.4.0-next.de618c7d; >=0.4.0-next.ded32dc6 <0.4.0-next.ec5f7b16; >=0.4.0-next.ecd79892 <1.39.0-next.16

Direct Vulnerabilities

Known vulnerabilities in the @theia/plugin-ext package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Improper Verification of Source of a Communication Channel

@theia/plugin-ext is a Theia - Plugin Extension

Affected versions of this package are vulnerable to Improper Verification of Source of a Communication Channel via the postMessage() function, which allows Webview contents to be hijacked.

How to fix Improper Verification of Source of a Communication Channel?

Upgrade @theia/plugin-ext to version 1.18.0 or higher.

<1.18.0