25.3.4
5 years ago
4 days ago
Known vulnerabilities in the @vaadin/charts package. This does not include vulnerabilities belonging to this package’s dependencies.
Snyk's AI Trust Platform automatically finds the best upgrade path and integrates with your development workflows. Secure your code at zero cost.
Fix for free| Vulnerability | Vulnerable Version |
|---|---|
@vaadin/charts is a vaadin-charts Affected versions of this package are vulnerable to Cross-site Scripting (XSS) in the chart configuration process. An attacker can execute arbitrary JavaScript code in the context of the user's browser by injecting malicious data into configuration options such as How to fix Cross-site Scripting (XSS)? Upgrade | >=22.0.0 <23.6.7>=24.0.0 <24.4.19>=24.5.0 <24.7.13>=24.8.0 <24.9.19>=24.10.0 <24.10.7>=25.0.0 <25.2.14>=25.3.0 <25.3.1 |