address-rfc2822 vulnerabilities

RFC 2822 & 5322 (Header) email address parser

Direct Vulnerabilities

Known vulnerabilities in the address-rfc2822 package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Regular Expression Denial of Service (ReDoS)

<2.0.2

Package versions

1 - 14 of 14 Results
version published direct vulnerabilities
2.2.0 23 Feb, 2024
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
2.1.0 26 Feb, 2021
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
2.0.6 18 Nov, 2020
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
2.0.5 3 Jun, 2020
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
2.0.4 30 Jun, 2018
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
2.0.3 1 Mar, 2018
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
2.0.2 25 Feb, 2018
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
2.0.1 26 Jun, 2017
  • 0
    C
  • 1
    H
  • 0
    M
  • 0
    L
2.0.0 21 Jun, 2017
  • 0
    C
  • 1
    H
  • 0
    M
  • 0
    L
1.0.1 23 Sep, 2016
  • 0
    C
  • 1
    H
  • 0
    M
  • 0
    L
1.0.0 24 Feb, 2016
  • 0
    C
  • 1
    H
  • 0
    M
  • 0
    L
0.0.2 2 May, 2013
  • 0
    C
  • 1
    H
  • 0
    M
  • 0
    L
0.0.1 15 Mar, 2013
  • 0
    C
  • 1
    H
  • 0
    M
  • 0
    L
0.0.0 15 Mar, 2013
  • 0
    C
  • 1
    H
  • 0
    M
  • 0
    L