atropa-ide@0.1.0 vulnerabilities

An ide for web development using ckeditor and ace.

Direct Vulnerabilities

Known vulnerabilities in the atropa-ide package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Directory Traversal

atropa-ide is an IDE for web development using ckeditor and ace..

Affected versions of the package are vulnerable to Directory Traversal, which may allow access to sensitive files and data on the server. For example, requesting the following url /..%2f..%2fetc/passwd would result in /etc/passwd leak.

How to fix Directory Traversal?

There is no fixed version for atropa-ide.

*
  • H
Directory Traversal

atropa-ide is an IDE for web development using ckeditor and ace..

Affected versions of the package are vulnerable to Directory Traversal, which may allow access to sensitive files and data on the server. For example, requesting the following url /..%2f..%2fetc/passwd would result in /etc/passwd leak.

How to fix Directory Traversal?

There is no fixed version for atropa-ide.

*