bignum@0.12.5 vulnerabilities

Arbitrary-precision integer arithmetic using OpenSSL

Direct Vulnerabilities

Known vulnerabilities in the bignum package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Malicious Package

bignum is a malicious package. The affected package versions are using node-pre-gyp to optionally download pre-built binary versions of the addon. These binaries were published on a now-expired S3 bucket which has since been claimed by a malicious third party which is now serving binaries containing malware that exfiltrates data from the user's computer.


Only versions v0.12.2 to v0.13.0 of this package contain malware. Users can continue using non-impacted versions.

v0.13.1 does not use node-pre-gyp and does not have support for downloading pre-built binaries in any form, avoiding the risk of malicious downloads.

How to fix Malicious Package?

Upgrade bignum to version 0.13.1 or higher.

>=0.12.2 <0.13.1
  • H
Denial of Service (DoS)

bignum is an Arbitrary precision integral arithmetic for Node.js using OpenSSL.

This library is based on node-bigint by substack, but instead of using libgmp, it uses the builtin bignum functionality provided by OpenSSL. The advantage is that OpenSSL is already part of Node.js, so this library does not add any external dependency whatsoever.

Affected versions of this package are vulnerable to Denial of Service (DoS) due to a type-check exception in V8, when verifying the type of the second argument to the .powm function, V8 will crash regardless of Node try/catch blocks.

How to fix Denial of Service (DoS)?

There is no fixed version for bignum.