boom@0.1.0 vulnerabilities

HTTP-friendly error objects

Direct Vulnerabilities

Known vulnerabilities in the boom package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Cross-site Scripting (XSS)

boom is an npm package that provides a set of utilities for returning HTTP errors. Affected versions of the package are vulnerable to Cross-site Scripting (XSS).

How to fix Cross-site Scripting (XSS)?

Upgrade boom to version 0.3.0 or higher.

<0.3.0
  • M
Cross-site Scripting (XSS)

boom is an npm package that provides a set of utilities for returning HTTP errors. Affected versions of the package are vulnerable to Cross-site Scripting (XSS).

How to fix Cross-site Scripting (XSS)?

Upgrade boom to version 0.3.0 or higher.

<0.3.0