browserify-sign@2.7.3 vulnerabilities

adds node crypto signing for browsers

Direct Vulnerabilities

Known vulnerabilities in the browserify-sign package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Improper Verification of Cryptographic Signature

Affected versions of this package are vulnerable to Improper Verification of Cryptographic Signature in the dsaVerify function. An attacker can construct signatures that can be successfully verified by any public key, leading to a signature forgery attack. This is achieved by exploiting an upper bound check issue in the checkValue function, which incorrectly checks the upper bound of the passed parameters.

Note: This vulnerability affects all places in the project that involve DSA verification of user-input signatures.

How to fix Improper Verification of Cryptographic Signature?

Upgrade browserify-sign to version 4.2.2 or higher.

>=2.6.0 <4.2.2