electron@10.2.0 vulnerabilities

Build cross platform desktop apps with JavaScript, HTML, and CSS

Direct Vulnerabilities

Known vulnerabilities in the electron package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in regular expressions (V8).

How to fix Use After Free?

Upgrade electron to version 15.5.3, 16.2.4, 17.4.2 or higher.

<15.5.3 >=16.0.0 <16.2.4 >=17.0.0 <17.4.2
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in Network Service

How to fix Use After Free?

Upgrade electron to version 20.1.2, 19.1.0, 18.3.12 or higher.

>=20.0.0 <20.1.2 >=19.0.0 <19.1.0 <18.3.12
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in Layout.

How to fix Use After Free?

Upgrade electron to version 19.1.0, 18.3.14 or higher.

>=19.0.0 <19.1.0 <18.3.14
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in WebSQL.

How to fix Use After Free?

Upgrade electron to version 18.3.12, 19.0.16, 20.1.2 or higher.

<18.3.12 >=19.0.0 <19.0.16 >=20.0.0 <20.1.2
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in SwiftShader.

How to fix Use After Free?

Upgrade electron to version 19.0.15 or higher.

<19.0.15
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in Blink, when a DisplayLock is unlocked via ForceUnlockIfNeeded.

How to fix Use After Free?

Upgrade electron to version 18.3.11 or higher.

<18.3.11
  • M
Improper Authentication

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Authentication by allowing the creation of cookies that have an empty name field and whose value impersonates a cookie name prefix.

Note:

Upgrading to the fixed version will delete any previously stored cookies that meet the conditions by causing them to fail their IsCanonical() check.

How to fix Improper Authentication?

Upgrade electron to version 18.3.11 or higher.

<18.3.11
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free when glBufferData redefines a buffer and the new buffer is smaller than the old buffer.

How to fix Use After Free?

Upgrade electron to version 18.3.11, 19.0.15 or higher.

<18.3.11 >=19.0.0 <19.0.15
  • M
Access Control Bypass

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Access Control Bypass due to insufficient policy enforcement in Cookies.

How to fix Access Control Bypass?

Upgrade electron to version 18.3.9, 19.0.12 or higher.

<18.3.9 >=19.0.0 <19.0.12
  • M
Buffer Overflow

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Buffer Overflow when changing the PDF layout confuses AddFindResult() and causes it to fail a DCHECK()

How to fix Buffer Overflow?

Upgrade electron to version 18.3.8, 19.0.13 or higher.

<18.3.8 >=19.0.0 <19.0.13
  • M
Improper Input Validation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation. in Internals, due to not treating % as a special character in pathname resolution.

NOTE: This vulnerability is only exploitable when running on Windows.

How to fix Improper Input Validation?

Upgrade electron to version 18.3.8, 19.0.13 or higher.

<18.3.8 >=19.0.0 <19.0.13
  • M
Information Exposure

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Information Exposure in Background Fetch, by exposing URLs during cross-origin redirects.

How to fix Information Exposure?

Upgrade electron to version 18.3.9, 19.0.12 or higher.

<18.3.9 >=19.0.0 <19.0.12
  • H
Denial of Service (DoS)

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Denial of Service (DoS) in PDF in Google Chrome, a remote attacker to potentially exploit heap corruption via a crafted HTML page.

How to fix Denial of Service (DoS)?

Upgrade electron to version 17.4.11, 18.3.7 or higher.

<17.4.11 >=18.0.0 <18.3.7
  • H
Type Confusion

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Type Confusion in V8.

How to fix Type Confusion?

Upgrade electron to version 17.4.11, 18.3.6 or higher.

<17.4.11 >=18.0.0 <18.3.6
  • H
Heap-based Buffer Overflow

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Heap-based Buffer Overflow in the WebRTC component.

How to fix Heap-based Buffer Overflow?

Upgrade electron to version 17.4.11, 18.3.6 or higher.

<17.4.11 >=18.0.0 <18.3.6
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in File System API.

How to fix Use After Free?

Upgrade electron to version 16.2.6, 17.4.3, 18.2.2 or higher.

<16.2.6 >=17.0.0 <17.4.3 >=18.0.0 <18.2.2
  • M
Protection Mechanism Failure

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Protection Mechanism Failure in File System API.

How to fix Protection Mechanism Failure?

Upgrade electron to version 17.4.9, 18.3.6, 19.0.7 or higher.

<17.4.9 >=18.0.0 <18.3.6 >=19.0.0 <19.0.7
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in Angle.

How to fix Use After Free?

Upgrade electron to version 17.4.8, 18.3.4 or higher.

<17.4.8 >=18.0.0 <18.3.4
  • M
Exposure of Resource to Wrong Sphere

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Exposure of Resource to Wrong Sphere which allows a renderer with JS execution to obtain access to a new renderer process even without nodeIntegrationInSubFrames being enabled, that allows effective access to ipcRenderer.

How to fix Exposure of Resource to Wrong Sphere?

Upgrade electron to version 15.5.6, 16.2.6, 17.2.0, 18.0.0 or higher.

<15.5.6 >=16.0.0 <16.2.6 >=17.0.0 <17.2.0 >=18.0.0-beta.1 <18.0.0
  • M
Improper Input Validation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation which allows attackers who have control over a given app's update server or update storage to serve maliciously crafted update packages that pass the code signing validation check but contain malicious code in some components.

How to fix Improper Input Validation?

Upgrade electron to version 15.5.0, 16.2.0, 17.2.0, 18.0.0 or higher.

<15.5.0 >=16.0.0 <16.2.0 >17.0.0 <17.2.0 >=18.0.0-beta.1 <18.0.0
  • M
Improper Input Validation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation in Data Transfer, because the sanitization code only does one round of parsing and serializing.

How to fix Improper Input Validation?

Upgrade electron to version 17.4.8, 18.3.5 or higher.

<17.4.8 >=18.0.0 <18.3.5
  • H
Heap-based Buffer Overflow

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Heap-based Buffer Overflow in V8 Internationalization.

How to fix Heap-based Buffer Overflow?

Upgrade electron to version 15.5.6, 16.2.7, 17.4.5 or higher.

<15.5.6 >=16.0.0-alpha.1 <16.2.7 >=17.0.0-alpha.1 <17.4.5
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free due to improper cache state validation after the XFB buffer was deleted.

How to fix Use After Free?

Upgrade electron to version 15.5.6, 16.2.7, 17.4.5 or higher.

<15.5.6 >=16.0.0-alpha.1 <16.2.7 >=17.0.0-alpha.1 <17.4.5
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in the BFCache, due to the attempts to cache an interstitial which results in a crash.

How to fix Use After Free?

Upgrade electron to version 16.2.4, 17.4.2 or higher.

<16.2.4 >=17.0.0-alpha.1 <17.4.2
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in Vulkan.

How to fix Use After Free?

Upgrade electron to version 15.5.6, 16.2.6, 17.4.4 or higher.

<15.5.6 >=16.0.0-alpha.1 <16.2.6 >=17.0.0-alpha.1 <17.4.4
  • H
Inappropriate implementation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Inappropriate implementation in Input.

How to fix Inappropriate implementation?

Upgrade electron to version 15.5.5, 16.2.6, 17.4.4, 18.2.2 or higher.

<15.5.5 >=16.0.0 <16.2.6 >=17.0.0 <17.4.4 >=18.0.0 <18.2.2
  • H
Improper Input Validation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation in Blink Editing.

How to fix Improper Input Validation?

Upgrade electron to version 15.5.4, 16.2.6, 17.4.3, 18.2.2 or higher.

<15.5.4 >=16.0.0 <16.2.6 >=17.0.0 <17.4.3 >=18.0.0 <18.2.2
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in Angle, when pausing XFB then deleting a buffer.

How to fix Use After Free?

Upgrade electron to version 15.5.4, 16.2.6, 17.4.3 or higher.

<15.5.4 >=16.0.0 <16.2.6 >=17.0.0 <17.4.3
  • H
Type Confusion

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Type Confusion in V8.

How to fix Type Confusion?

Upgrade electron to version 15.5.3, 16.2.3, 17.4.1 or higher.

<15.5.3 >=16.0.0 <16.2.3 >=17.0.0 <17.4.1
  • M
Type Confusion

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Type Confusion in V8.

How to fix Type Confusion?

Upgrade electron to version 15.5.3, 16.2.4, 17.4.2 or higher.

<15.5.3 >=16.0.0 <16.2.4 >=17.0.0 <17.4.2
  • M
Improper implementation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper implementation in Compositing.

How to fix Improper implementation?

Upgrade electron to version 15.5.3, 16.2.4 or higher.

<15.5.3 >=16.0.0 <16.2.4
  • H
Heap-based Buffer Overflow

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Heap-based Buffer Overflow in WebGPU.

How to fix Heap-based Buffer Overflow?

Upgrade electron to version 16.2.5, 17.4.3 or higher.

<16.2.5 >=17.0.0 <17.4.3
  • M
Inappropriate implementation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Inappropriate implementation in WebGL.

How to fix Inappropriate implementation?

Upgrade electron to version 16.2.5, 17.4.3 or higher.

<16.2.5 >=17.0.0 <17.4.3
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in SwiftShader.

How to fix Use After Free?

Upgrade electron to version 15.5.4, 16.2.5, 17.4.3 or higher.

<15.5.4 >=16.0.0 <16.2.5 >=17.0.0 <17.4.3
  • M
Inappropriate implementation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Inappropriate implementation in Web Cursor.

How to fix Inappropriate implementation?

Upgrade electron to version 15.5.4, 16.2.3, 17.4.1 or higher.

<15.5.4 >=16.0.0 <16.2.3 >=17.0.0 <17.4.1
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in Device API.

How to fix Use After Free?

Upgrade electron to version 15.5.4, 16.2.5, 17.4.3 or higher.

<15.5.4 >=16.0.0 <16.2.5 >=17.0.0 <17.4.3
  • C
Type Confusion

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Type Confusion in V8 Turbofan, exploiting this vulnerability is possible via a crafted HTML page.

How to fix Type Confusion?

Upgrade electron to version 15.5.3, 16.2.4, 17.4.2 or higher.

<15.5.3 >=16.0.0 <16.2.4 >=17.0.0 <17.4.2
  • M
Information Exposure

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Information Exposure where ImageBitmaps that is created by webGL contexts will fail to render.

How to fix Information Exposure?

Upgrade electron to version 14.2.8, 15.4.2, 16.2.0 or higher.

<14.2.8 >=15.0.0 <15.4.2 >=16.0.0 <16.2.0
  • H
Type Confusion

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Type Confusion due to mishandling of interceptors which can lead to out-of-bounds memory access.

How to fix Type Confusion?

Upgrade electron to version 15.5.0, 16.2.0 or higher.

<15.5.0 >=16.0.0 <16.2.0
  • M
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free via Angle, where base level changes may not update FBO completeness check.

How to fix Use After Free?

Upgrade electron to version 16.2.0 or higher.

<16.2.0
  • L
Improper Access Control

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Access Control via the web Bluetooth API, if the app has not configured a custom select-bluetooth-device event handler. The device that is accessed is random and the attacker would have no way of selecting a specific device.

How to fix Improper Access Control?

Upgrade electron to version 13.6.6, 14.2.4, 15.3.5, 16.0.6, 17.0.0-alpha.6 or higher.

<13.6.6 >=14.0.0-beta.25 <14.2.4 >=15.0.0-beta.1 <15.3.5 >=16.0.0-beta.1 <16.0.6 >=17.0.0-alpha.1 <17.0.0-alpha.6
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free on context loss.

How to fix Use After Free?

Upgrade electron to version 14.2.7, 15.4.0, 16.0.10 or higher.

<14.2.7 >=15.0.0 <15.4.0 >=16.0.0 <16.0.10
  • H
Improper Check or Handling of Exceptional Conditions

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Check or Handling of Exceptional Conditions which returns an invalid handle after ReportBadMessage

How to fix Improper Check or Handling of Exceptional Conditions?

Upgrade electron to version 14.2.7, 15.4.0, 16.0.10 or higher.

<14.2.7 >=15.0.0 <15.4.0 >=16.0.0 <16.0.10
  • H
Integer Overflow or Wraparound

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Integer Overflow or Wraparound due to handle reuse in Mojo.

How to fix Integer Overflow or Wraparound?

Upgrade electron to version 14.2.7, 15.4.0 or higher.

<14.2.7 >=15.0.0 <15.4.0
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free when the source framebuffer's extents were accidentally used instead of the blit area extents.

How to fix Use After Free?

Upgrade electron to version 14.2.7, 15.4.0, 16.0.10 or higher.

<14.2.7 >=15.0.0 <15.4.0 >=16.0.0 <16.0.10
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free via the Animation component in Chromium.

How to fix Use After Free?

Upgrade electron to version 16.0.10, 17.1.0 or higher.

<16.0.10 >=17.0.0 <17.1.0
  • C
Improper Input Validation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation via Mojo. If the endpoint's task runner does not match the current task runner (or an equivalent main-thread task runner for the ChannelProxy) when executing a message dispatch task for that endpoint, it dispatches it on the wrong sequence.

How to fix Improper Input Validation?

Upgrade electron to version 13.6.8, 14.2.4, 15.3.5 or higher.

<13.6.8 >=14.0.0 <14.2.4 >=15.0.0 <15.3.5
  • M
Improper Control of a Resource Through its Lifetime

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Control of a Resource Through its Lifetime in the FramebufferAttachment::mRenderToTextureSamples method in Angle. It was never updated if the renderbuffer storage was changed after attaching to framebuffer.

How to fix Improper Control of a Resource Through its Lifetime?

Upgrade electron to version 13.6.8, 14.2.4, 15.3.6 or higher.

<13.6.8 >=14.0.0 <14.2.4 >=15.0.0 <15.3.6
  • H
Interger Underflow

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Interger Underflow in ANGLE. A remote attacker could potentially exploit heap corruption via a crafted HTML page.

How to fix Interger Underflow?

Upgrade electron to version 14.2.5, 15.3.6 or higher.

<14.2.5 >=15.0.0 <15.3.6
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in media in Google Chrome which allows a remote attacker to potentially exploit heap corruption via a crafted HTML page.

How to fix Use After Free?

Upgrade electron to version 15.3.5 or higher.

<15.3.5
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in V8.

How to fix Use After Free?

Upgrade electron to version 13.6.6, 14.2.4 or higher.

<13.6.6 >=14.0.0 <14.2.4
  • H
Type Confusion

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Type Confusion in loader in Google Chrome. This can lead to heap corruption which is exploited through a crafted HTML page.

How to fix Type Confusion?

Upgrade electron to version 13.6.6, 14.2.4, 15.3.5 or higher.

<13.6.6 >=14.0.0 <14.2.4 >=15.0.0 <15.3.5
  • H
Type Confusion

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Type Confusion in V8 in Google Chrome allows a remote attacker to potentially exploit heap corruption via a crafted HTML page.

How to fix Type Confusion?

Upgrade electron to version 13.6.8, 14.2.5, 15.3.6 or higher.

<13.6.8 >=14.0.0 <14.2.5 >=15.0.0 <15.3.6
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free via file API in Google Chrome prior to 96.0.4664.93. It allows a remote attacker who have compromised the renderer process to potentially exploit heap corruption via a crafted HTML page.

How to fix Use After Free?

Upgrade electron to version 13.6.6, 14.2.4, 15.3.5 or higher.

<13.6.6 >=14.0.0 <14.2.4 >=15.0.0 <15.3.5
  • H
Type Confusion

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Type Confusion in V8. This allows a remote attacker to potentially exploit heap corruption via a crafted HTML page.

How to fix Type Confusion?

Upgrade electron to version 13.6.3, 14.2.2, 15.3.3 or higher.

<13.6.3 >=14.0.0 <14.2.2 >=15.0.0 <15.3.3
  • M
Inappropriate Implementation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Inappropriate Implementation via cache in Google Chrome. This allows a remote attacker to leak cross-origin data via a crafted HTML page.

How to fix Inappropriate Implementation?

Upgrade electron to version 13.6.6, 14.2.2, 15.3.3 or higher.

<13.6.6 >=14.0.0 <14.2.2 >=15.0.0 <15.3.3
  • M
Inappropriate Implementation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Inappropriate Implementation via service workers in Google Chrome. This allows a remote attacker who had compromised the renderer process to bypass site isolation via a crafted HTML page.

How to fix Inappropriate Implementation?

Upgrade electron to version 14.2.2, 15.3.3 or higher.

<14.2.2 >=15.0.0 <15.3.3
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in loader in Google Chrome. This allows a remote attacker to potentially exploit heap corruption via a crafted HTML page.

How to fix Use After Free?

Upgrade electron to version 13.6.3, 14.2.2, 15.3.3 or higher.

<13.6.3 >=14.0.0 <14.2.2 >=15.0.0 <15.3.3
  • M
Domain Spoofing

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Domain Spoofing via a crafted HTML page as a result of inappropriate implementation in navigation in Google Chrome.

How to fix Domain Spoofing?

Upgrade electron to version 16.0.0 or higher.

<16.0.0
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in the storage foundation, which allows a remote attacker to potentially exploit heap corruption via a crafted HTML page

How to fix Use After Free?

Upgrade electron to version 16.0.0 or higher.

<16.0.0
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free via the Web Transport module in Chromium.

How to fix Use After Free?

Upgrade electron to version 14.2.1, 13.6.2 or higher.

>=14.0.0 <14.2.1 <13.6.2
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free via the Garbage Collection module in Chromium.

How to fix Use After Free?

Upgrade electron to version 14.2.1, 13.6.2, 12.2.3 or higher.

>=14.0.0 <14.2.1 >=13.0.0 <13.6.2 <12.2.3
  • C
Type Confusion

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Type Confusion via the V8 module in Chromium.

How to fix Type Confusion?

Upgrade electron to version 14.2.1, 13.6.2, 12.2.3 or higher.

>=14.0.0 <14.2.1 >=13.0.0 <13.6.2 <12.2.3
  • H
Heap-based Buffer Overflow

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Heap-based Buffer Overflow via the WebRTC module in Chromium.

How to fix Heap-based Buffer Overflow?

Upgrade electron to version 14.2.0, 13.5.2, 12.2.3 or higher.

>=14.0.0 <14.2.0 >=13.0.0 <13.5.2 <12.2.3
  • M
Information Exposure

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Information Exposure via the core module in Chromium.

How to fix Information Exposure?

Upgrade electron to version 14.2.0, 13.5.2, 12.2.2 or higher.

>=14.0.0 <14.2.0 >=13.0.0 <13.5.2 <12.2.2
  • H
Heap-based Buffer Overflow

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Heap-based Buffer Overflow via the Blink module in Chromium.

How to fix Heap-based Buffer Overflow?

Upgrade electron to version 14.2.0, 13.5.2 or higher.

>=14.0.0 <14.2.0 <13.5.2
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free via heap corruption through a crafted HTML page.

How to fix Use After Free?

Upgrade electron to version 14.1.1, 13.5.2, 12.2.2 or higher.

>=14.0.0 <14.1.1 >=13.0.0 <13.5.2 <12.2.2
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in the file system API, through a heap corruption via a crafted HTML page.

How to fix Use After Free?

Upgrade electron to version 14.1.1, 13.5.2, 12.2.2 or higher.

>=14.0.0 <14.1.1 >=13.0.0 <13.5.2 <12.2.2
  • M
Exposure of Resource to Wrong Sphere

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Exposure of Resource to Wrong Sphere. Inappropriate implementation in Background Fetch API in Google Chrome prior to 94.0.4606.54 allowed a remote attacker to leak cross-origin data via a crafted HTML page.

How to fix Exposure of Resource to Wrong Sphere?

Upgrade electron to version 14.1.1, 13.5.2, 12.2.2 or higher.

>=14.0.0 <14.1.1 >=13.0.0 <13.5.2 <12.2.2
  • M
Improper Access Control

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Access Control. Inappropriate implementation in Background Fetch API in Google Chrome prior to 94.0.4606.54 allowed a remote attacker who had compromised the renderer process to leak cross-origin data via a crafted HTML page.

How to fix Improper Access Control?

Upgrade electron to version 14.1.1, 13.5.2, 12.2.2 or higher.

>=14.0.0 <14.1.1 >=13.0.0 <13.5.2 <12.2.2
  • M
Sandbox Bypass

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Sandbox Bypass via chromium, due to a child process's delayed integrity level not being set correctly.

How to fix Sandbox Bypass?

Upgrade electron to version 12.2.2, 13.5.2, 14.2.0 or higher.

<12.2.2 >=13.0.0 <13.5.2 >=14.0.0 <14.2.0
  • M
Information Exposure

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Information Exposure. A sandboxed renderer can request a "thumbnail" image of an arbitrary file on the user's system. Note: This can be partially fixed by enabling contextIsolation.

How to fix Information Exposure?

Upgrade electron to version 11.5.0, 12.1.0, 13.3.0, 14.0.0, 15.0.0-alpha.10 or higher.

>=10.1.0 <11.5.0 >=12.0.0-beta.1 <12.1.0 >=13.0.0-beta.2 <13.3.0 >=14.0.0-beta.1 <14.0.0 >=15.0.0-alpha.1 <15.0.0-alpha.10
  • M
Improper Input Validation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation. It is possible to kill a renderer if it provides an unexpected FrameOwnerElementType.

How to fix Improper Input Validation?

Upgrade electron to version 13.5.1, 12.2.1 or higher.

>=13.0.0 <13.5.1 <12.2.1
  • M
Improper Input Validation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation. Insufficient validation exist in the svg painting code which may access a content-visibility locked element via an svg reference.

How to fix Improper Input Validation?

Upgrade electron to version 14.1.0, 13.5.1, 12.2.1 or higher.

>=14.0.0 <14.1.0 >=13.0.0 <13.5.1 <12.2.1
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in Indexed DB API.

How to fix Use After Free?

Upgrade electron to version 13.5.0, 12.2.0 or higher.

>=13.0.0 <13.5.0 <12.2.0
  • H
Buffer Overflow

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Buffer Overflow in ANGLE.

How to fix Buffer Overflow?

Upgrade electron to version 13.5.0, 12.2.0 or higher.

>=13.0.0 <13.5.0 <12.2.0
  • H
Out-of-Bounds

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Out-of-Bounds in ANGLE.

How to fix Out-of-Bounds?

Upgrade electron to version 13.5.0, 12.2.0 or higher.

>=13.0.0 <13.5.0 <12.2.0
  • H
Access Restriction Bypass

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Access Restriction Bypass in Blink.

How to fix Access Restriction Bypass?

Upgrade electron to version 13.5.0, 12.2.0 or higher.

>=13.0.0 <13.5.0 <12.2.0
  • H
Type Confusion

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Type Confusion in Blink layout.

How to fix Type Confusion?

Upgrade electron to version 13.5.0, 12.2.0 or higher.

>=13.0.0 <13.5.0 <12.2.0
  • H
Type Confusion

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Type Confusion via Blink layout in Chrome.

How to fix Type Confusion?

Upgrade electron to version 13.5.0, 12.2.0 or higher.

>=13.0.0 <13.5.0 <12.2.0
  • M
Out-of-Bounds

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Out-of-Bounds. An out of bounds write issue exists in engine.

How to fix Out-of-Bounds?

Upgrade electron to version 13.5.0, 12.1.2 or higher.

>=13.0.0 <13.5.0 <12.1.2
  • M
Heap-based Buffer Overflow

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Heap-based Buffer Overflow in WebGL via Chrome. This allows a remote attacker to potentially exploit heap corruption via a crafted HTML page.

How to fix Heap-based Buffer Overflow?

Upgrade electron to version 13.1.8, 12.0.16, 11.4.11 or higher.

>=13.0.0 <13.1.8 >=12.0.0 <12.0.16 <11.4.11
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in WebSerial via Chrome.

How to fix Use After Free?

Upgrade electron to version 12.0.16, 11.4.11 or higher.

>=12.0.0 <12.0.16 <11.4.11
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in Autofill.

How to fix Use After Free?

Upgrade electron to version 12.0.16, 11.4.11 or higher.

>=12.0.0 <12.0.16 <11.4.11
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in GPU.

How to fix Use After Free?

Upgrade electron to version 13.1.8, 12.0.16, 11.4.11 or higher.

>=13.0.0 <13.1.8 >=12.0.0 <12.0.16 <11.4.11
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in Blink XSLT.

How to fix Use After Free?

Upgrade electron to version 12.0.16, 11.4.11 or higher.

>=12.0.0 <12.0.16 <11.4.11
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in V8 via Chrome.

How to fix Use After Free?

Upgrade electron to version 12.0.16, 11.4.11 or higher.

>=12.0.0 <12.0.16 <11.4.11
  • M
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free via sqlite. This can allow a remote attacker to potentially exploit heap corruption via a crafted HTML page.

How to fix Use After Free?

Upgrade electron to version 13.1.8, 12.0.16, 11.4.11 or higher.

>=13.0.0 <13.1.8 >=12.0.0 <12.0.16 <11.4.11
  • H
Type Confusion

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Type Confusion in V8 via Chrome.

How to fix Type Confusion?

Upgrade electron to version 12.0.16, 11.4.11 or higher.

>=12.0.0 <12.0.16 <11.4.11
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in WebRTC.

How to fix Use After Free?

Upgrade electron to version 12.0.14, 11.4.10 or higher.

>=12.0.0-beta.1 <12.0.14 <11.4.10
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in WebAudio.

How to fix Use After Free?

Upgrade electron to version 12.0.14, 11.4.10 or higher.

>=12.0.0 <12.0.14 <11.4.10
  • C
Out-of-bounds Write

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Out-of-bounds Write via ANGLE in Chrome.

How to fix Out-of-bounds Write?

Upgrade electron to version 12.0.13, 11.4.10 or higher.

>=12.0.0 <12.0.13 <11.4.10
  • H
Access of Resource Using Incompatible Type ('Type Confusion')

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Access of Resource Using Incompatible Type ('Type Confusion'). Type confusion in V8 in Google Chrome allows a remote attacker to potentially exploit heap corruption via a crafted HTML page.

How to fix Access of Resource Using Incompatible Type ('Type Confusion')?

Upgrade electron to version 12.0.12, 11.4.9 or higher.

>=12.0.0-beta.1 <12.0.12 <11.4.9
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in BFCache in Google Chrome, which allows a remote attacker to potentially exploit heap corruption via a crafted HTML page.

How to fix Use After Free?

Upgrade electron to version 12.0.13, 11.4.9 or higher.

>=12.0.0-beta.1 <12.0.13 <11.4.9
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free. Use after free in Loader in Google Chrome allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

How to fix Use After Free?

Upgrade electron to version 12.0.12, 11.4.9 or higher.

>=12.0.0-beta.1 <12.0.12 <11.4.9
  • M
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in Network service.

How to fix Use After Free?

Upgrade electron to version 12.0.13, 11.4.10 or higher.

>=12.0.0 <12.0.13 <11.4.10
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in WebGL.

How to fix Use After Free?

Upgrade electron to version 12.0.13, 11.4.10 or higher.

>=12.0.0 <12.0.13 <11.4.10
  • H
Heap-based Buffer Overflow

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Heap-based Buffer Overflow in Media Feeds.

How to fix Heap-based Buffer Overflow?

Upgrade electron to version 12.0.10, 11.4.8, 10.4.7 or higher.

>=12.0.0-beta.1 <12.0.10 >=11.0.0-beta.1 <11.4.8 <10.4.7
  • H
Race Condition

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Race Condition in Aura.

How to fix Race Condition?

Upgrade electron to version 12.0.10, 11.4.8, 10.4.7 or higher.

>=12.0.0-beta.1 <12.0.10 >=11.0.0-beta.1 <11.4.8 <10.4.7
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in Notifications.

How to fix Use After Free?

Upgrade electron to version 12.0.10, 11.4.8, 10.4.7 or higher.

>=12.0.0-beta.1 <12.0.10 >=11.0.0-beta.1 <11.4.8 <10.4.7
  • H
Type Confusion

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Type Confusion in V8.

How to fix Type Confusion?

Upgrade electron to version 12.0.10, 11.4.8, 10.4.7 or higher.

>=12.0.0-beta.1 <12.0.10 >=11.0.0-beta.1 <11.4.8 <10.4.7
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in File API.

How to fix Use After Free?

Upgrade electron to version 12.0.10, 11.4.8, 10.4.7 or higher.

>=12.0.0-beta.1 <12.0.10 >=11.0.0-beta.1 <11.4.8 <10.4.7
  • H
Heap-based Buffer Overflow

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Heap-based Buffer Overflow in History.

How to fix Heap-based Buffer Overflow?

Upgrade electron to version 12.0.10, 11.4.8, 10.4.7 or higher.

>=12.0.0-beta.1 <12.0.10 >=11.0.0-beta.1 <11.4.8 <10.4.7
  • H
Heap-based Buffer Overflow

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Heap-based Buffer Overflow in Reader Mode.

How to fix Heap-based Buffer Overflow?

Upgrade electron to version 12.0.10, 11.4.8, 10.4.7 or higher.

>=12.0.0-beta.1 <12.0.10 >=11.0.0-beta.1 <11.4.8 <10.4.7
  • L
Out Of Bounds Read

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Out Of Bounds Read. Blit11 would clip the destination rectangle with the destination size but ignore the result. gl::ClipRectangle returns false when the rectangles do not intersect at all, indicating the blit can be skipped.

How to fix Out Of Bounds Read?

Upgrade electron to version 10.4.4, 11.4.4, 12.0.6 or higher.

<10.4.4 >=11.0.0 <11.4.4 >=12.0.0 <12.0.6
  • M
Improper Input Validation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation due to insufficient data validation that exists in V8.

How to fix Improper Input Validation?

Upgrade electron to version 10.4.4, 12.0.6 or higher.

<10.4.4 >=12.0.0 <12.0.6
  • H
Integer Overflow or Wraparound

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Integer Overflow or Wraparound via the Mojo component of chromium.

How to fix Integer Overflow or Wraparound?

Upgrade electron to version 10.4.4, 12.0.6 or higher.

<10.4.4 >=12.0.0 <12.0.6
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free via the Navigation component of chromium.

How to fix Use After Free?

Upgrade electron to version 10.4.4, 11.4.4, 12.0.6 or higher.

<10.4.4 >=11.0.0 <11.4.4 >=12.0.0 <12.0.6
  • H
Integer Overflow

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Integer Overflow via Chromium in Mojo.

How to fix Integer Overflow?

Upgrade electron to version 10.4.4 or higher.

<10.4.4
  • H
Heap-based Buffer Overflow

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Heap-based Buffer Overflow via V8.

How to fix Heap-based Buffer Overflow?

Upgrade electron to version 10.4.4, 11.4.4, 12.0.6 or higher.

<10.4.4 >=11.0.0 <11.4.4 >=12.0.0 <12.0.6
  • H
Out-of-bounds Read

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Out-of-bounds Read via the IPC in chromium.

How to fix Out-of-bounds Read?

Upgrade electron to version 11.4.4, 10.4.4 or higher.

>=11.0.0 <11.4.4 <10.4.4
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in the chromium extensions resource.

How to fix Use After Free?

Upgrade electron to version 11.4.4, 10.4.4 or higher.

>=11.0.0 <11.4.4 <10.4.4
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free via a vulnerability that exists in Blink in Chromium. A remote attacker can trick the victim to visit a specially crafted web page, trigger a use-after-free error and execute arbitrary code on the system.

How to fix Use After Free?

Upgrade electron to version 11.4.4, 10.4.4 or higher.

>=11.0.0 <11.4.4 <10.4.4
  • C
Out-of-bounds

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Out-of-bounds via the V8 component in Chrome.

How to fix Out-of-bounds?

Upgrade electron to version 11.4.4, 10.4.4, 12.0.6 or higher.

>=11.0.0 <11.4.4 <10.4.4 >=12.0.0 <12.0.6
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free via chromium which allows a remote attacker to potentially exploit heap corruption via a crafted HTML page.

How to fix Use After Free?

Upgrade electron to version 12.0.5, 11.4.4, 10.4.4 or higher.

>=12.0.0 <12.0.5 >=11.0.0 <11.4.4 <10.4.4
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free via Aura in Google Chrome which allowed a remote attacker who had compromised the renderer process to potentially exploit heap corruption via a crafted HTML page.

How to fix Use After Free?

Upgrade electron to version 12.0.5, 11.4.4, 10.4.4 or higher.

>=12.0.0 <12.0.5 >=11.0.0 <11.4.4 <10.4.4
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free via Chrome which allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

How to fix Use After Free?

Upgrade electron to version 12.0.5, 11.4.4, 10.4.4 or higher.

>=12.0.0 <12.0.5 >=11.0.0 <11.4.4 <10.4.4
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free. It allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

How to fix Use After Free?

Upgrade electron to version 10.4.2, 11.4.1 or higher.

<10.4.2 >=11.0.0 <11.4.1
  • H
Improper Input Validation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation. It allowed a remote attacker to leak cross-origin data via a crafted HTML page.

How to fix Improper Input Validation?

Upgrade electron to version 10.4.2, 11.4.1 or higher.

<10.4.2 >=11.0.0 <11.4.1
  • M
Access Restriction Bypass

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Access Restriction Bypass. Inappropriate implementation in Referrer in Google Chrome prior to 89.0.4389.72 allowed a remote attacker to bypass navigation restrictions via a crafted HTML page. This vulnerability relates to an electron component.

How to fix Access Restriction Bypass?

Upgrade electron to version 10.4.3, 11.4.1 or higher.

<10.4.3 >=11.0.0-beta.1 <11.4.1
  • H
Out-of-Bounds

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Out-of-Bounds. Out of bounds memory access in V8 in Google Chrome prior to 89.0.4389.72 allowed a remote attacker to potentially perform out of bounds memory access via a crafted HTML page. This vulnerability relates to an electron component.

How to fix Out-of-Bounds?

Upgrade electron to version 10.4.2, 11.4.1 or higher.

<10.4.2 >=11.0.0 <11.4.1
  • H
Out-of-bounds Write

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Out-of-bounds Write via a data race in the audio component. A remote attacker could potentially exploit heap corruption using a crafted HTML page.

How to fix Out-of-bounds Write?

Upgrade electron to version 10.4.1, 11.4.1 or higher.

<10.4.1 >=11.0.0 <11.4.1
  • H
Insecure Defaults

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Insecure Defaults. Insufficient policy enforcement in the File System API of chromium allows a remote attacker to bypass filesystem restrictions via a crafted HTML page.

How to fix Insecure Defaults?

Upgrade electron to version 10.4.1, 11.4.1 or higher.

<10.4.1 >=11.0.0 <11.4.1
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free. When a LayoutInline is removed, LineBoxList::DirtyLinesFromChangedChild tries to mark affected RootInlineBox dirty.

When the |LayoutInline| to be removed is culled, it tries to find the RootInlineBox from its previous siblings, then look for its previous and next RootInlineBoxes.

Occasionally, the next next line of the previous sibling is wrapped at the LayoutInline, and that its LineBreakObj() holds the reference to the LayoutInline. This patch marks such RootInlineBox dirty.

How to fix Use After Free?

Upgrade electron to version 11.4.0, 10.4.1 or higher.

>=11.0.0-beta.1 <11.4.0 <10.4.1
  • M
Information Exposure

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Information Exposure. The is a side-channel information leakage in autofill.

How to fix Information Exposure?

Upgrade electron to version 11.4.0, 10.4.1 or higher.

>=11.0.0-beta.1 <11.4.0 <10.4.1
  • H
Heap Buffer Overflow

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Heap Buffer Overflow via WebAudio.

How to fix Heap Buffer Overflow?

Upgrade electron to version 11.4.0, 10.4.1 or higher.

>=11.0.0-beta.1 <11.4.0 <10.4.1
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in WebRTC.

How to fix Use After Free?

Upgrade electron to version 11.4.0, 10.4.1 or higher.

>=11.0.0-beta.1 <11.4.0 <10.4.1
  • H
Out-of-Bounds

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Out-of-Bounds. Object lifecycle issue in audio.

How to fix Out-of-Bounds?

Upgrade electron to version 11.4.0, 10.4.1 or higher.

>=11.0.0-beta.1 <11.4.0 <10.4.1
  • H
Insufficient Validation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Insufficient Validation via an unknown issue in chromium.

How to fix Insufficient Validation?

Upgrade electron to version 9.4.2, 10.3.1, 11.2.2 or higher.

<9.4.2 >=10.0.0 <10.3.1 >=11.0.0 <11.2.2
  • C
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free via handling of cookies.

How to fix Use After Free?

Upgrade electron to version 9.4.2, 10.3.1, 11.2.2 or higher.

<9.4.2 >=10.0.0 <10.3.1 <11.2.2
  • M
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free via the Blink component in chromium.

How to fix Use After Free?

Upgrade electron to version 9.4.2, 10.3.1, 11.2.2 or higher.

<9.4.2 >=10.0.0 <10.3.1 >=11.0.0 <11.2.2
  • M
Improper Input Validation

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation via the File System API.

How to fix Improper Input Validation?

Upgrade electron to version 11.2.1, 9.4.4 or higher.

>=10.0.0-beta.1 <11.2.1 <9.4.4
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free. It hands sub-queries with both a correlated WHERE clause and a HAVING 0 clause where the parent query is itself an aggregate.

How to fix Use After Free?

Upgrade electron to version 11.2.1, 9.4.4 or higher.

>=10.0.0-beta.1 <11.2.1 <9.4.4
  • H
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in Media.

How to fix Use After Free?

Upgrade electron to version 11.2.1, 9.4.4 or higher.

>=10.0.0-beta.1 <11.2.1 <9.4.4
  • C
Use After Free

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free. An unknown vunerability exists in Chrome.

How to fix Use After Free?

Upgrade electron to version 9.4.1, 10.3.2 or higher.

<9.4.1 >=10.0.0 <10.3.2
  • H
Out-of-bounds Read

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Out-of-bounds Read. An unknown vunerability exists in Chrome which affects electron.

How to fix Out-of-bounds Read?

Upgrade electron to version 9.4.1, 10.3.2 or higher.

<9.4.1 >=10.0.0 <10.3.2
  • M
Information Exposure

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Information Exposure. When a BigInt is right-shifted the backing store is not properly cleared, allowing uninitialized memory to be read.

How to fix Information Exposure?

Upgrade electron to version 9.4.1, 10.3.2 or higher.

<9.4.1 >=10.0.0 <10.3.2