genieacs@1.2.7 vulnerabilities

A TR-069 Auto Configuration Server (ACS)

Direct Vulnerabilities

Known vulnerabilities in the genieacs package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • C
Command Injection

genieacs is an A TR-069 Auto Configuration Server (ACS) Affected versions of this package are vulnerable to Command Injection via the ping host argument (lib/ui/api.ts and lib/ping.ts) which stems from insufficient input validation combined with a missing authorization check.

How to fix Command Injection?

Upgrade genieacs to version 1.2.8 or higher.

>=1.2.0 <1.2.8