gm@0.5.0 vulnerabilities

GraphicsMagick and ImageMagick for node.js

Direct Vulnerabilities

Known vulnerabilities in the gm package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Remote Shell Command Injection

The gm package is the GraphicsMagick and ImageMagick wrapper for Node.js. The compare() function allows comparing of two images, taking as an input argument the path to both images. The function, in versions prior to 1.21.1, fails to sanitize the input correctly, making it vulnerable to a command injection attack.

How to fix Remote Shell Command Injection?

Upgrade gm to version 1.21.1 or greater.

If a direct dependency update is not possible, use snyk wizard to patch this vulnerability.

<=1.20.0