graphql@16.7.1 vulnerabilities

A Query Language and Runtime which can target any service.

Direct Vulnerabilities

Known vulnerabilities in the graphql package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Denial of Service (DoS)

Affected versions of this package are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance.

Note: It was not proven that this vulnerability can crash the process.

How to fix Denial of Service (DoS)?

Upgrade graphql to version 16.8.1 or higher.

>=16.3.0 <16.8.1