hawk@4.0.0 vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the hawk package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Regular Expression Denial of Service (ReDoS)

hawk is a library for the HTTP Hawk Authentication Scheme.

Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) in header parsing where each added character in the attacker's input increases the computation time exponentially.

How to fix Regular Expression Denial of Service (ReDoS)?

Upgrade hawk to version 9.0.1 or higher.

<9.0.1
  • L
Regular Expression Denial of Service (ReDoS)

hawk is an HTTP authentication scheme using a message authentication code (MAC) algorithm to provide partial HTTP request cryptographic verification.

Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) attacks.

<3.1.3 >=4.0.0 <4.1.1