ip@0.2.0 vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the ip package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Uninitialized Memory Exposure

ip is an IP address utility for node.js.

Affected versions of the package are vulnerable to Uninitialized Memory Exposure due to an insecure use of the Node.js Buffer class.

How to fix Uninitialized Memory Exposure?

Upgrade ip to version 1.1.5 or higher. Note This is vulnerable only for Node <=4

<1.1.5