jquery-ui@1.12.0-beta.1 vulnerabilities

A curated set of user interface interactions, effects, widgets, and themes built on top of the jQuery JavaScript Library.

Direct Vulnerabilities

Known vulnerabilities in the jquery-ui package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Cross-site Scripting (XSS)

jquery-ui is a library for manipulating UI elements via jQuery.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) via the initialization of check-box-radio widget on an input tag enclosed within a label, which leads to the parent label contents being considered as the input label.

Exploiting this vulnerability is possible if a .checkboxradio( "refresh" ) call is executed on such a widget, and the initial HTML contains encoded HTML entities, leading them to be erroneously decoded.

How to fix Cross-site Scripting (XSS)?

Upgrade jquery-ui to version 1.13.2 or higher.

<1.13.2
  • H
Cross-site Scripting (XSS)

jquery-ui is a library for manipulating UI elements via jQuery.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) when accepting the value of the of option of the .position() util from untrusted sources which may lead to execution of untrusted code.

How to fix Cross-site Scripting (XSS)?

Upgrade jquery-ui to version 1.13.0 or higher.

<1.13.0
  • H
Cross-site Scripting (XSS)

jquery-ui is a library for manipulating UI elements via jQuery.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) when accepting the value of altField option of the Datepicker widget from untrusted sources, which may lead to execution of untrusted code.

POC

Initializing the 'datepicker' in the following way:

$( "#datepicker" ).datepicker( {
    altField: "<img onerror='doEvilThing()' src='/404' />",
} );

will call the doEvilThing function.

How to fix Cross-site Scripting (XSS)?

Upgrade jquery-ui to version 1.13.0 or higher.

<1.13.0
  • H
Cross-site Scripting (XSS)

jquery-ui is a library for manipulating UI elements via jQuery.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS). When accepting the value of various *Text options of the Datepicker widget from untrusted sources it may lead to execution of untrusted code.

###POC Initializing the 'Datepicker' in the following way:

$( "#datepicker" ).datepicker( {
    showButtonPanel: true,
    showOn: "both",
    closeText: "<script>doEvilThing( 'closeText XSS' )</script>",
    currentText: "<script>doEvilThing( 'currentText XSS' )</script>",
    prevText: "<script>doEvilThing( 'prevText XSS' )</script>",
    nextText: "<script>doEvilThing( 'nextText XSS' )</script>",
    buttonText: "<script>doEvilThing( 'buttonText XSS' )</script>",
    appendText: "<script>doEvilThing( 'appendText XSS' )</script>",
} );

will call the doEvilThing() function.

How to fix Cross-site Scripting (XSS)?

Upgrade jquery-ui to version 1.13.0 or higher.

<1.13.0